Add typescript reference missing

If I create a new project with:

dotnet-new angular-spa test

Then when I open this project there is no context menu option for “add typescript reference”.

If I go into one of my existing project the context menu is there. I have the latest cli and servicestackvs extension installed. I have replicated on my desktop and laptop.

Why is the context menu option missing to add the reference?

ps. I am able to add the reference with CLI. It is just the Visual Studio context menu that is missing.

Looks like it’s only shown on Web Project Types, will look into it. You can use the npm ts-ref or .NET Core web ts tools to add TypeScript References in the meantime.

But you should be able to Update ServiceStack Reference for the dtos.d.ts that already exists right?

I tried copying one from another project initially and doing that. It threw an object reference exception

Sorry what threw an object reference Exception?

When I tried to update from context menu after copying the file in from another project.