Charles Wyandt - 6 - Mar 6, 2015

I’m having an odd issue installing the Nuget package for ServiceStack.Client on a Xamarin.iOS XForms project, receiving this error:
"Could not install package ‘ServiceStack.Interfaces 4.0.38’. You are trying to install this package into a project that targets ‘Xamarin.iOS, Version=v1.0’, but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author."

The page at
seems to claim that Xamarin.iOS is supported, but this is claiming otherwise?
P.S. I have tried several versions of the ServiceStack.Client package, to no avail.

Edit: I am on Visual Studio 2015 CTP 5, and have tried CTP 6 with similar results- Android projects and portable class libraries seem to install and function correctly, so this just leaves iOS nonfunctional.

Annoying. ServiceStack.Interfaces.dll is a pure PCL dll that should also be compatible with Unified API. As a workaround you should be able to manually reference ServiceStack.Interfaces.dll from the NuGet /packages folder.

I’ll update the NuGet packages to include to also list it in the profile.

This change should now work with the ServiceStack.Client NuGet package on MyGet:

Charles Wyandt:

So that worked everywhere but iOS, and partially in that particular area: ServiceStack.Text is still producing the original targeting error when I attempt to install .Client.

ok weird, I wasn’t getting this error with a local Xamarin forms iOS project. I’ve also added the NuGet profile to ServiceStack.Text which you can get from MyGet, as you already have an existing v4.0.39 installed you’ll need to clear your NuGet cache and /packages folder, see:

Charles Wyandt:

The issue seems to be correlated to the usage of Nuget from the vs2015 preview, as 2013 works fine for it.