`dotnet run` hangs when trying to run any of the .NET 5 templates

Hello there!

I am trying to create a new project using the vue-nuxt template and I am getting an error where running dotnet run just leads to a hanging process (no output or error stack trace). I have also tried using the react-spa template to see if it was specific to the vue-nuxt template but the same behavior occurred.

Here is what I did that lead up to this point:

PS C:\> dotnet --version
PS C:\> node --version
PS C:\> x new vue-nuxt TestingNuxt
... (generated project correctly)
PS C:\TestingNuxt\TestingNuxt> npm install
... (npm install worked correctly)
PS C:\TestingNuxt\TestingNuxt> dotnet run
(no output, just hangs)

I am pretty lost in terms of finding out what the actual root cause is. I created a new normal .NET 5.0 Web Application in Visual Studio and changed the .NET version to 5.0 to see if that works (which it did).

Also, the application is binding to the port but navigating to the page just results in an empty response.

Another interesting observation is that it did work on a machine with .NET version 5.0.100, but I can’t imagine that a .001 version bump would break things this badly :slight_smile:.

I would greatly appreciate any ideas or thoughts on this.

Are you sure it’s hanging and not just running without logging output? Can you view the website at https://localhost:5001?

Ah! Going to https://localhost:5001 works, my browser was defaulting to http which results in an empty response.

Thanks for your help!

1 Like