Error when updating dtos in react-spa 2.1 template (or angular template)

Hello, I am trying to update dtos, but not sure what I am doing wrong. I run the command “npm run dtos” and it returns error code 255. Some of the log output is at the very bottom of this message.

When I run typescript-ref directly, I get the following:

“Timothys-MBP:shared glacier$ typescript-ref
unable to verify the first certificate”

I tried this in the Angular template and get similar results.

The error log is below when I run “npm run dtos”

Thank you for your help with this.


Log below:

0 info it worked if it ends with ok
1 verbose cli [ ‘/Users/glacier/.nvm/versions/node/v10.13.0/bin/node’,
1 verbose cli ‘/Users/glacier/.nvm/versions/node/v10.13.0/bin/npm’,
1 verbose cli ‘run’,
1 verbose cli ‘dtos’ ]
2 info using npm@6.4.1
3 info using node@v10.13.0
4 verbose run-script [ ‘predtos’, ‘dtos’, ‘postdtos’ ]
5 info lifecycle my-app@0.1.0~predtos: my-app@0.1.0
6 info lifecycle my-app@0.1.0~dtos: my-app@0.1.0
7 verbose lifecycle my-app@0.1.0~dtos: unsafe-perm in lifecycle true
8 verbose lifecycle my-app@0.1.0~dtos: PATH: /Users/glacier/.nvm/versions/node/v10.13.0/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/Users/glacier/dev/z/react-spa/MyApp/node_modules/.bin:/Library/Frameworks/Python.framework/Versions/3.7/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/share/dotnet:~/.dotnet/tools:/Library/Frameworks/Mono.framework/Versions/Current/Commands:/Applications/Xamarin
9 verbose lifecycle my-app@0.1.0~dtos: CWD: /Users/glacier/dev/z/react-spa/MyApp
10 silly lifecycle my-app@0.1.0~dtos: Args: [ ‘-c’, ‘typescript-ref’ ]
11 silly lifecycle my-app@0.1.0~dtos: Returned: code: 255 signal: null
12 info lifecycle my-app@0.1.0~dtos: Failed to exec dtos script
13 verbose stack Error: my-app@0.1.0 dtos: typescript-ref
13 verbose stack Exit status 255
13 verbose stack at EventEmitter. (/Users/glacier/.nvm/versions/node/v10.13.0/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:301:16)
13 verbose stack at EventEmitter.emit (events.js:182:13)
13 verbose stack at ChildProcess. (/Users/glacier/.nvm/versions/node/v10.13.0/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack at ChildProcess.emit (events.js:182:13)
13 verbose stack at maybeClose (internal/child_process.js:962:16)
13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:251:5)
14 verbose pkgid my-app@0.1.0
15 verbose cwd /Users/glacier/dev/z/react-spa/MyApp/src
16 verbose Darwin 18.2.0
17 verbose argv “/Users/glacier/.nvm/versions/node/v10.13.0/bin/node” “/Users/glacier/.nvm/versions/node/v10.13.0/bin/npm” “run” “dtos”
18 verbose node v10.13.0
19 verbose npm v6.4.1
20 error code ELIFECYCLE
21 error errno 255
22 error my-app@0.1.0 dtos: typescript-ref
22 error Exit status 255
23 error Failed at the my-app@0.1.0 dtos script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 255, true ]

What’s your OS and version and what is this a log of?

Can you try upgrading to the latest version of @servicestack/cli and let me know if it’s still an issue?

$ npm install -g @servicestack/cli@latest

Updating the CLI as you mentioned works! I didn’t realize the ServiceStack CLI needed to be updated. Just to be complete here, I am running MacOS 10.14.1 and the log was a file that was generated in my terminal after running the “npm run dtos” command.

But it worked just by updating the CLI…thank you very much.

1 Like