Hosted ui ignores PathName when redirecting to MicrosoftGraphAuthProvider

I am trying to use the built in /ui that comes with ServiceStack. I have declared a PathBase like this
app.UseServiceStack(new AppHost(env.IsDevelopment())
PathBase = “/prod”,
AppSettings = new NetCoreAppSettings(Configuration)
When I click on the button for Microsoft login the page im directed to is missing the PathBase and does not work. How can this be fixed?

Hi @mikeg,

This sounds like the configured RedirectUrl for your auth provider. Can you check you have the full path populated for both the CallbackUrl and RedirectUrl to match the PathBase you are using during startup? For example, here is the config used in our TechStacks app.

The RedirectUrl and the CallBack url are populated with the redirect being our React ui and the CallBack is our api with the correct path on it. I tried just setting both of these to the api with the correct path and the behavior is still the same.

Thanks @mikeg,

I think I might be misunderstanding the issue, can you confirm the login using the MicrosoftGraphAuthProvider works and the problem is only when using the API Explorer built in login form that you have the problem? Eg here


Yes that is correct only having a problem with the API explorer built in login.

@mikeg this issue should now be resolved and available on MyGet. Let us know if you have any related issues when trying to use the MicrosoftGraphAuthProvider with API Explorer login.