Info: Rider 2022.3.2 required adding ConfigureProfiling

This might be helpful information for others, as it cost me too much time to resolve.

I recently updated to Rider 2022.3.2 and afterwards I could no longer debug Blazor Wasm apps in neither Chrome nor Edge. The apps functioned correctly when Run. The browser error was:

NotSupportedException: Required Plugin ‘ProfilingFeature’ was not registered

Using another computer with the previous Rider 2022.3.1, debugging worked without an issue.

Eventually, I resolved the problem by configuring ServiceStack profiling, as described here:

public class ConfigureProfiling : IHostingStartup
    public void Configure(IWebHostBuilder builder)
        builder.ConfigureAppHost(host => {
            host.Plugins.AddIfDebug(new RequestLogsFeature {
                EnableResponseTracking = true,
            host.Plugins.AddIfDebug(new ProfilingFeature {
                IncludeStackTrace = true,

No idea, why a Rider update required me to add a ServiceStack profiling configuration, but with the above added to my application, browser debugging worked again.

(FYI: Windows 10; Net7, ServiceStack 6.5.1; Blazor WASM)

This error suggests your App is configured to listen to diagnostic events, is your App listening to any DiagnosticListener diagnostic events?

You can also tell ServiceStack to not profile any requests in your AppHost by overriding:

public override bool ShouldProfileRequest(IRequest req) => false;
1 Like

As far as I know, I am not listening to diagnostic events. But, if my app was, why would browser debugging in the previous Rider work? There were no code changes between updating Rider and browsers were at their latest releases.

I wont be able to tell from here, maybe you have a dirty cache and its using old binaries.

When issues like this happen I recommend clearing out all binaries and caches so you can have a fresh start, by deleting .idea, bin and obj folders and performing a full rebuild.

I just had to do this as well. Simple upgrade of Rider and this error starts popping up. Thank-you @Keith for posting this.

Out of interest, were you running IIS Express when you hit this problem? @Charles / @Keith

No, I was not. Its def. a weird bug.

Also, not using IIS Express.

Thanks both, I saw this issue once with IIS but sounds unrelated, this helps narrow it down! :+1: