License valid when local, but invalid when deployed

I have a very strange case regarding licensing, tried using both “application start” and approaches, both yield the same result. Project was created using the SS bootstrap/razor templates in VS.

My license is valid and ranges until mid-2016, and updated nuget to latest version (42).

  • When I run a web-application locally it starts up fine, I can authenticate and use the app.
  • When I deploy to a hosting provider, it throws an Invalid License exception.

I have copied web.config, the dlls, everything as-is. I considered maybe a conflict due to shared-hosting provider, but the exception reports my correct license id number.

Thoughts anyone?

Self-corrected … License was a red herring. By adding “allowNestedErrors=true” to the custom errors tag, I saw that the underlying exception was due to lacking “full trust” in the web.config.

For future reference:

    <customErrors mode="Off" allowNestedErrors ="true" />
    <trust level="Full" />