Locode filter issue in some templates?

I downloaded the chinook example and everything works perfectly. The filter in the locode grid works and show up etc.

I’ve tried some templates on this page: https://jamstacks.net

Namely Next,js and Vue SSG

Once logged as admin I go to:


The filters on the grid do not seem to work and once I click on them the UI does not respond anymore. Clicking on + New Booking won’t do anything etc. If I don’t click on the filter first I can create booking etc. in both template and I see the requests coming in on the service up till I click on a filter.

After clicking on a filter I can see the service isn’t receiving any request anymore and the ui is not responding.

Am I missing a build step or something that could explain this behaviour?


Can you try upgrading to the latest v6.3.1 on MyGet which has a number of locode fixes.

Yes (sorry for the delay different time zone).

I’m now using the myget packages (6.3.1) and I still have the same issue only when downloading the Vue SSG template project from https://jamstacks.net

But if I install the template using x it works and the filters works etc.

Maybe something changed and the templates are not updated yet on that website?

When using the downloaded template and running:

cd ui && npm run build:local

I’m getting

vue-tsc --noEmit && vite-ssg build --mode development

'vue-tsc' is not recognized as an internal or external command,
operable program or batch file.

One thing I’ve noticed is that even when using x after the build finishes there is a warning but everything still works.

[vite-ssg] Build finished.
[vite-ssg] Build process still running after 15s. There might be something misconfigured in your setup. Force exit.

Then the issue is likely due to not having run migrate to create the database:

$ npm run migrate

DB migrations was a feature added in the last release.

But this should’ve been run when you installed npm dependencies:

$ npm install

Did you install the deps before running the app?

I think I forgot to switched to myget the second time I downloaded the project.

I’m pretty sure I ran npm install in the ui folder I recall there were some security warnings and I checked the database in datagrip and the bookings were created.

I ran npm install again cleared the browser cache and it works now.

Does npm run build:local need to be run every time before running npm run dev?

After install npm runs the postinstall script which runs the migration task:

No, build:local builds the static site that can run locally in the .NET App, dev runs the dev version of the node vite site.

1 Like