Mike Mertsock - 371 - Dec 4, 2014

Is there any known issue with the Add ServiceStack Reference tool in the latest ServiceStackVS extension? When we enter a valid URL and name and click OK in the dialog, nothing happens (literally: the UI doesn’t react, can’t find any log or console output, etc.). If we enter an invalid URL, we get an error message. We tried this with Visual Studio 2013 Update 3 and Update 4.

Shouldn’t be, does {BaseUrl}/types/csharp return the generated DTO’s or does it generate an error? 

If it does return the DTO’s without error, can you try reinstalling the latest SSVS from:
The UX for Add SS Ref has been slightly improved. 

Mike Mertsock:

The /types/csharp URL works fine when I point a web browser to it. I’ll try the new vsix when I have some time. Thanks

Mike Mertsock:

I think the issue may be related to HTTPS URLs. Our public facing API is only available via HTTPS, and our load balancer does not redirect non-https requests, it just kills the connection. If I use an http:// address pointing to the internal hostname of our server, the Add ServiceStack Reference tool works fine (but this workaround wouldn’t be possible for our customers).

Also, our ServiceStack instance is configured with an “/api” base path instead of being at the root (so the full path is /api/types/csharp). I noticed that the generated dtos.cs file does not include the /api path in the BaseUrl value at the top of the file. This is causing the Update ServiceStack Reference command to fail. If I manually edit the file to include the /api path, the update command works correctly (but the /api path is removed again). Not sure whether this will affect others who have their API hosted at a different path, due to some weirdness in our config, but I wanted to mention it.

Thanks Mike, I’ll get +Darren Reid (maintainer of SSVS) to look into the https issue. Does it work if you put the full 'https://url` in? hopefully shouldn’t have to redirect in that case. Also if your https endpoint is available that will help with testing on our end.

The /api BaseUrl issue should be resolved in: https://github.com/ServiceStack/Issues/issues/177
which is available from v4.0.34 on MyGet: https://github.com/ServiceStack/ServiceStack/wiki/MyGet

Mike Mertsock:

Thanks for the notice on the base path change, I’ll try that out if I have time. I tried the full URL, that doesn’t work either. I’m emailing you the URL of our endpoint.

Darren Reid:

Hi +Mike Mertsock , Issue with SSVS should now be resolved with adding HTTPS endpoints. You can download the latest from GitHub.


The update should also work once the server has been updated to include the fix on 4.0.34. Let me know if you have other problems. 

Mike Mertsock:

Thanks, that works now!