Nuget version issues

When I run “dotnet-new vue-spa myname”. I get a project with a nuget.config wich contains key to servicestack myget. Then I restore nuget packages. And I get servicestack 5.0.1. And it again depends on some servicestack packages that are version 5.1.0. But those packages are not on nuget or myget.

Apologies, should be resolved now. You’ll likely need to clear your NuGet cache:

$ nuget locals all -clear

You may need to remove your /bin and /obj folders as well, or you can just create a new project.

1 Like

Did you mean nuget localls all -clear?
It worked.

I had some issues getting this up an running. I did not realize that I had to run “dotnet run” in addition to “npm run dev”.

Yeah I meant nuget, muscle memory wrote npm :slight_smile: (fixed typo)

Yeah you’ll need to run dotnet run to run the .NET Core server and leave npm run dev running in the background to run a live watched build to recompile changes to client source files.

You can also run dotnet watch run (instead of dotnet run) to run a watched server build where .NET Core will recompile and restart the app when it detects any server source file changes.

1 Like