'Random' Google Authentication Error

I am using the angular template, wired up the new GoogleAuthProvider. Everything seems to work fine on one dev machine, however, on my other dev machine, I always get a reply f=Unknown. I tried poaching another implementation from the forum (I think @mythz created for some interum use before 5.5) and can’t seem to get any breakpoint hit. I dont see it even called on my debugger stack.

Sorry, Ive been away from ServiceStack for awhile, tried to find an answer, I’m sure I must have something misconfigured.


I don’t know what the question is? But if you’re using a local copy of GoogleAuthProvider.cs then you’ll be able to debug it like any other C# class.

Make sure you’re using your local copy, e.g. ctrl+clicking the class to make sure it’s going to your impl or change the namespace of your local copy and use the fully qualified type in your AuthFeature.

Whenever trying to debug any integration issues like this, always look at the raw HTTP Request/Response headers to compare the working vs the non working requests.