S3VirtualFiles: GetFiles() return always empty list

Hi guys,
I’m trying to download some file from my s3storage but when I execute GetFiles() in my directory I always receive an empty list.

As you can see from the previous pic, “files” variable value is 0, but my folder contain 2 files


The user I’m using to access the s3 storage has the AmazonS3ReadOnlyAccess authorization.
What am I doing wrong?

I already tried by using every methods that should return files on a folder, such as Files property, GetFiles(), GetAllFiles() and GetAllMatchingFiles(“*”) with the same result.

I’m trying with ServiceStack.Aws nuget package version 6.9.0 within a console application targetting Framework 4.7.1

Best regards

Hi @Mares40,

I can reproduce the problem when I use prefixes containing = it seems. However, this issue seems to also occur when using the official AWS CLI. Eg, can you try to perform the command:

aws s3 ls s3://prod-fpt-datalake-datalake/machineMetrics/ --recursive

And see if any files under the prefix machineID=CT020 are present? When I’ve tested this with my own bucket, I can still see files up until the prefix with the = sign but then nothing when I expect to see multiple files.

Ok, It was my fault.
There are no issue related on “=” char, but the path were I was looking in was wrong and not receiving any exception I didn’t recognize it.

Changing it to the right path everything works great



I was a bit quick setting up the reproduction and looks like I had different permissions on the prefixes I created. Glad it’s sorted, thanks for letting us know.