ServiceStack &

I’m having trouble using (latest v3.6.3), ServiceStack.Quartz.dll (v5.8) with latest ServiceStack (6.9) in my .net core project.
Project compiles fine but at run time, I get the error:
Could not load type ‘ServiceStack.MetadataFeatureExtensions’ from assembly ‘ServiceStack, Version=, …’
Not idea where the reference to the old servicestack is coming. I did clear my nuget cache, but that didn’t make a difference.
Funny thing is that this worked fine before I upgraded to .net core 6.9.
Any ideas on how to fix this?

Hi @mbo27 , The ServiceStack.Quartz is a community package not maintained by the ServiceStack team, but it looks like that package tied to both ServiceStack 5.8 and Quartz 3.0.7 as you’ve said. Your error does sound like dirty DLLs, what version of ServiceStack/.NET Core are you updating from?

It does look like there is a more up to date community package on NuGet and GitHub you might have more luck with?

To avoid binary incompatibility issues you should be running the same version of ServiceStack that the library uses, for many community libraries this might mean you’d need to build it from source to bump the ServiceStack version that you’re using, then if you send a PR they’re more likely to publish it on their NuGet.

I’m using latest version of Quartz (v3.6.3) which has no dependancy on ServiceStack. Issue I think is with ServiceStack.Quartz which is the library that allows using Quartz with ServiceStack. I’m using again the latest version (v5.8.0) which claims a dependancy on ServiceStack.Server >= 5.8.0, but somewhere there is a reference to
You’re referring to a newer version, I think I’m using the latest (v5.8 is what Nuget/GitHub are showing - udpated 3 years ago!). Am I missing something?

Right, I don’t think you will be able to use the community library ServiceStack.Quartz with ServiceStack 6.9, as you will likely hit binary incompatibilities as @mythz said.

@mbo27 we had the same issue. I sent a PR to update to 6.3 but unfortunately there has been no movements. Here is a link to the PR Upgrade to ServiceStack 6.3 by DeonHeyns · Pull Request #17 · wwwlicious/ServiceStack.Quartz · GitHub, we ended up forking the library for our needs.

1 Like

I ended doing the same: recompiling it locally.

It is a pity it is no longer maintained. I had looked at moving everything to Background Services but the Quartz approach worked better for us. I think @mythz mentioned somewhere about using something like pingdom to call a service endpoint to kick off tasks as an alternative.