Servicestack XS requires monodevelop 6.0

I’m running ubuntu 16.04 with the latest mono (5.10) installed. When I try to update the ServiceStack XS addin via the addin-manager in monodevelop. I get the error shown in the attached image.

I tried to uninstall then install the addin again. But now I got this error:

The files it it searching for is located, on my machine, here :
and not here:

I found this blogpost, stating that monodevleop is broken on ubuntu 16.04

and this issue on ubuntu bugtracker:

I added the GPG signing key and downgraded monodevelop to As explained in the issue linked above. This helped somewhat. Now atleast my “Mono soft debugger support for” is working again. And now I got a little furter when trying to install the Servicestack SS plugin. But it still failed with a warning saying it requires some Monodevelop v6.0 packages.

So I guess I need to update monodevelop to 6.0. But then I have to find some repos which has beta or alpha builds of monodevelop.

Unfortunatelly, MonoDevelop v6.0 (which is required by ServiceStackXS addin) is not shipped for Linux. Moreover Monodevelop 6.0 even does not start on Linux if compile it from source code without additional hacking and fixing some bugs directly in the code. I posted this blocker bug half an year ago and posted what need to be changed in sources to fix it, but no one fixed it yet. So I am not sure that Xamarin will continue to support Monodevelop on linux.

Monodevelop in Ubuntu 16.04 and official Xamarin repo has the same version 5.10 and as you correctly noticed, Monodevelop from Ubuntu repo does not work with ASP.NET, while Monodevelop from Xamarin repo can not install version control plugin (if you need it). I resolved this by mixing installations from these two repos, if you interested I can look into details how I managed that.

@layoric can provide more info about is it possible to avoid ServiceStackXS dependency to Monodevelop 6.0 or not, but current ServiceStackXS requires MD6.0 on Mac


Thanks for answer.
For now, the only reason I need ServiceStack XS is so that I can add a servicestack reference to my project as described here:

I guess I’ll just work around this by manually updating the servicestack dto’s.

@ristaloff the latest version does require it to be built with 6.0 as a dependency. It’s strange that the addin manager even shows you this incompatible version as an option given the previous version is published that supports 5.x.

Could you please try download v0.4 from the link below and installing it from disk?

Ok I tried but it did not work.
In monodevelop I choose the addin-manager, then “Install from file” selected the “ServiceStackXS.ServiceStackXS-0.4.mpack” file, and I get this dialog:

Thats kinda weird, shouldn’t it say version 0.4? Anyway I click on “Install” and then I get this:

@ristaloff That is very strange. I’ve had all sorts of problems with the addins build server, sadly it’s the only way to publish addins so that users can install them from the IDE.

I’ve added a tag specifically for the last v0.4 build that targets v5.x and published it to replace the one that was broken (though looks like the v6 build has decided to stop picking up v6 IDE dependencies…)

If you can’t install it from the IDE, try the link below and let me know how it goes.

When I install from the IDE I now get version 0.4. But it fails with the same error message as above. That the files referenced in the manifest could not be found.

The link returns an 500 error.

@ristaloff Thanks for that. Seems the addins server is having issues. Build logs are throw 500s as well. I’ll get a VM running and post back when I have a working version.

@ristaloff I was able to reproduce the same error you are seeing on a fresh VM, was also seeing the same error for virtually all extensions sadly. However, after I restarted MonoDevelop, I started to see a slightly different error (which I didn’t screenshot…) however the extension worked (IE, I could bring up the Add ServiceStack Reference Dialog).

I removed the addins to try to clean up my install, removed monodevelop and now addins seem to install successfully. See below…

I’ll try to start with a clean VM again and capture my steps, though one thing to note is I first tried with the monodevelop version not, uninstalled that and install the xamarin2 one.

So it seems it’s possible to get it working, but sadly this is a problem with the Monodevelop build as all addins seem equally effected.

I managed to get the addin installed now. I followed a tips on this page:

"You can workaround the error message when installing an addin by renaming the file /usr/lib/monodevelop/AddIns/AspNet/MonoDevelop.AspNet.dll to MonoDevelop.AspNet.dll-bak although even though MonoDevelop says the installation fails it still seems to work. "

@ristaloff thanks for posting what worked for you. Really sucks that Monodevelop unstable/not working on linux.