Ui interface does not work after upgrading to 6.7

No idea what happened, but when i try to hit the /ui side (which used to work) it now shows a blank page and complains about being unauthorized. before it would prompt for creds. even when i use the login.html override and sign in ok, i can see a successful auth in my ide console, but i never get the ui page to display.

i do see this tho in dev tools

GET https://cyb-XXX-api:5000/js/core.mjs net::ERR_ABORTED 404

it looks like its calling the wrong url. my api sits at


is this the issue? all the other js references in dev tools includes the /capi/ from PathBase = “/capi” property

how do i get this working?

Do you have a custom auth provider?

Yeah this was an issue with the custom base path which should now be resolved from the latest v6.7.1+ that’s now available on MyGet.

You should also checkout the v6.7 Release Notes which details changes after all built-in UIs have been rewritten in the Vue 3.

It also shows the legacy routes to access the old UIs whilst all reported issues are resolved in this release.

I updated this morning from MyGet. Didn’t see a change.
Checked the file version in the application’s directory and the project’s versions and they are 6.7.1.
File date on 6.7.1 were 3/16/2023 5 am

Rolled back to 6.6.0 and all is well.
File dates for 6.6.0 are 2/7/2023 3 pm
Am I missing a step?

Make sure you do a full refresh to bypass any browser cache.

What’s your issue? Are you also hosting from a custom path? What are the console errors you’re seeing now?

1 Like

No I have a custom auth provider overriding AuthenticateAsync and TryAuthenticateAsync and a CustomGateway (which really doesn’t come into play yet).

I am also getting no UI anything. No login no list of query objects just a blank screen.

I am playing around to validate that restarting IIS might be the key or possibly if there is a cookie issue.

Are you getting a blank page, or a non-empty HTML page (i.e. visible in view source) that doesn’t render anything due to console errors? If you’re getting console errors what are they?

does the old UI work at /ui-v1?

i do, but it worked fine before the vue3 change.

myget packages worked and i can see things as expected now

1 Like


The path to /js/core.mjs should be resolved in the latest v6.7.1 on MyGet.

Does /ui-v1 work? Do you know why /js/core.mjs is failing? it should resolve from your API’s BaseUrl, is it trying to request a different url?

i can confirm this DOES fix it

1 Like

Sorry brain fog on the ui-v1 question just got it.

Can’t tell what the issue is from here, may have something to do with your custom auth provider given Authentication is failing, tho it’s surprising the existing v1 UI doesn’t work either.

I’ll be able to identify and resolve it if you can provide a link to a stand-alone repro on GitHub.

So after your suggestion I went back and checked the custom auth and I was doing some stuff in the AuthenticateAsync with jwt and CreatteJwtHeader and CreateJwtPayload and I don’t know why. So I commented that out and viola!

1 Like