Upgrade to servicestack core 1.0.41, add reference to servicestack.interfaces build error

I’ve upgrade the asp.net core project to servicestack interfaces core 1.0.41 and when building the project I get this build error:

error CS0012: The type ‘AttributeBase’ is defined in an assembly that is not referenced. You must add a reference to assembly ‘ServiceStack.Interfaces, Version=, Culture=neutral, PublicKeyToken=null’.

(exception on the RequiredRole attribute)

The project has a reference to ServiceStack.Interfaces.Core v 1.0.41. I’ve cleaned the solution, restored nuget, but still this build error.

Do you have this exception if update to v1.0.42 which is available on MyGet?

Strange, I’ve updated all APIs on https://github.com/NetCoreApps/ which isn’t having this issue.

I’m compiling using .dotNETCoreApp 1.1 and cleared the nuget cache in VS 2017, but still the same build error

Can you try referencing the v1.0.42 .Core packages on MyGet as @xplicit suggested, you just need to add the feed in:

<?xml version="1.0" encoding="utf-8"?>
    <add key="nuget.org" value="https://api.nuget.org/v3/index.json" protocolVersion="3" />
    <add key="ServiceStack MyGet feed" value="https://www.myget.org/F/servicestack" />

If it’s still an issue we’ll need a repro, can you let me know if you’re getting the same issue with any of the NetCoreApps, otherwise can you put together a small stand-alone project that has this issue.

There is a difference in the package
Version 1.0.33

Version 1.0.41

and the content of ServiceStack.Interfaces.deps.json contains a reference to servicestack.interfaces.dll

      "runtimeTarget": {
        "name": ".NETStandard,Version=v1.1/",
        "signature": "850687991476de67f74c4ee527fc0755afc4f85c"
      "compilationOptions": {},
      "targets": {
        ".NETStandard,Version=v1.1": {},
        ".NETStandard,Version=v1.1/": {
          "servicestack.interfaces/4.5.9": {
            "dependencies": {
              "NETStandard.Library": "1.6.1",
              "System.Runtime.Serialization.Primitives": "4.3.0"
            "runtime": {
              "ServiceStack.Interfaces.dll": {}
          "microsoft.netcore.platforms/1.1.0": {},
          "microsoft.netcore.targets/1.1.0": {},
          "netstandard.library/1.6.1": {
  "libraries": {
    "servicestack.interfaces/4.5.9": {
      "type": "project",
      "serviceable": false,
      "sha512": ""
    "microsoft.netcore.platforms/1.1.0": {

I’ve got an other library https://www.nuget.org/packages/ServiceStack.Authentication.Azure
that has a dependency on servicestack.interfaces.core on >= 1.0.40… but it’s defined as a minimal version dependency, so it should match 1.0.41

So if remove reference to ServiceStack.Authentication.Azure package the issue has gone?

I’ve updated my solution to 1.0.42 from MyGet, but still the same build exception.

Did you remove reference to ServiceStack.Authentication.Azure package? This package is compiled with ServiceStack.Interfaces.dll v1.0 assembly, while latest nuget ServiceStack *.Core packages contain v4.5 of this assembly and the package won’t work with recent ServiceStack.Core releases.