Upgrading problem from 4.0.53 to 4.0.60

Hi, yesterday I was trying to upgrade the ServiceStack dependencies in my project from 4.0.53 to 4.0.60, but I was stuck with an error.
It seems that when I try to upgrade ServiceStack.Server, ServiceStack.OrmLite and ServiceStack.OrmLite.SqlServer my project loses every reference to System.Linq; to be more specific I get hundreds errors with the lambda operator:

Cannot convert lambda expression to type 'string' because it is not a delegate type    


‘...’ does not contain a definition for 'Where' and no extension method 'Where' accepting a first argument of type ‘...’ could be found (are you missing a using directive or an assembly reference?)

I’ve tried to declare using System.Linq; but Resharper highlighted it as useless… I’ve tried to add System.Data.Linq to my project references too, but nothing chenged.
Can anyone help me to find out the problem?

Does you project reference System.Core assembly? If this reference is missing compilation generates the same errors as you described above.

The latest Release Notes show that OrmLite has removed some deprecated APIs and shows workarounds.

Please provide an example of code that fails to build.

Thank you Demis, I refactored all my code and now it seems to work!
I have just one more question… How can I Select only some columns From my model with the new API?

Does the docs on Dynamic Result Sets show what you need? Otherwise please provide an example showing exactly what you want to do.

I’m simply trying to write this:

var zones = Db.Select<Countries>(@"SELECT AN02_PROV, AN02_IDNAZ_AN03
                                   FROM AN02_COM
                                   GROUP BY AN02_PROV, AN02_IDNAZ_AN03
                                   ORDER BY AN02_PROV");

…using the OrmLite API functions.

Ok so you’ll need to use one of the Dynamic Result Set API’s I linked to.